Delphi Berlin 10.1

    Delphi Berlin 10.1

    Liebe Delphi Gemeinde,

    Ich benutze in Delphi 6 Prof. einige der beliebten RX-Komponenten.
    Da ich nun Delphi Berlin 10.1 Prof. erworben habe, möchte ich einige Programme von Delphi 6 nach Delphi Berlin 10.1 übernehmen.

    Es gibt die RX-Komponenten jetzt auch für Delphi Berlin 10.1.
    Leider gelingt es mir nicht, diese in Delphi Berlin 10.1 zu installieren.

    Vielleicht haben einige von Euch das schon gemacht und könnten mir freundlicherweise eine detaillierte
    Anleitung geben, damit ich das auch schaffe.

    Hier der Link zu den Komponenten:
    micrel.cz/RxLib/files/unrxlib_275_u_1_0_17.rar

    Gruß Gringo
    Wo ist das Problem? Ich habe das Archiv in einen Ordner entpackt, unter Berlin dann die entsprechende Projektgruppe RxLib_D10_1Berlin.groupproj (unter RXLib\units\packages_D10_1_Berlin) geöffnet, in der Projektstruktur das oberste Package ausgewählt, das Kontextmenü aufgerufen, den Punkt "Ab hier -> Alle compilieren" angeklickt und nach erfolgreichem Kompiliervorgang die Designtime-Packages installiert. Ging einwandfrei.
    10 Minuten Nachdenken ersparen oftmals 10 Stunden Fehlersuche.
    Hallo DeddyH,

    ich hab es so gemacht wie Du es beschrieben hast.
    Delphi Berlin gestartet, über Datei öffnen die Datei "RxLib_D10_1Berlin.groupproj" geöffnet.
    Dann auf der rechten Seite die Datei "RtmRxCtl240.bpl" mit der rechten Maustaste angeklickt und im
    Kontexmenü "Alle Compilieren" angeklickt. Danach noch mal auf "Alle erzeugen".
    Aber den Punkt von Dir habe ich nicht gefunden "die Designtime-Packages installiert."
    Wo muss ich den suchen ??

    Gruß Gringo
    Hallo DeddyH,
    erst mal Danke für Deine Antworten.
    Nur bei 2 bpl- Dateien erscheint "Installieren".
    DclRxCtl240.bpl und DclRxDB240.bpl
    Wenn ich auf installieren klicke gibt es eine Fehlermeldung:
    Package 'RtmRxCtI240' kann nicht geladen werden.
    Es enthält die Unit 'RxResConst_ger', die auch im Package 'RX Comp' enthalten ist.

    Bei den anderen bpl-Dateien gibt es den Menüpunkt "Installieren" nicht.
    Was kann ich tun.
    Es liegt mir sehr an den Komponenten.

    Gruß Gringo
    Ich hatte das RX-Pack installiert, als es noch keine Version für 10.1 Berlin gab. Ich habe die Version für 10.0 Seattle und die Uses angepasst. Läuft bei mir problemlos. Ich kann dir das Zeug zusammenpacken und mailen, wenn du willst
    Glückauf

    Herr, wirf Hirn vom Himmel

    Ein Leben ohne Möpse ist möglich, aber sinnlos ( Loriot )
    Der beste Platz für Politiker ist das Wahlplakat. Dort ist er tragbar, geräuschlos und leicht zu entfernen ( Loriot )

    Es gibt Leute, die fühlen sich überall gedemütigt, wo sie nicht frech sein dürfen ( Otto Weiss )

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von „guinnes“ ()

    Hallo guinnes,

    das wäre sehr nett, wenn ich das RX-Pack von Dir bekommen könnte.
    Schreibe mir bitte wie Du die Installation gemacht hast.
    Ich bin darin nicht so firm.
    Meine E-Mail:
    Guinnes : Mailadresse gelöscht

    Gruss Gringo

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von „guinnes“ ()